1. install mikrotik

2. set ip address

/ip address
add address=192.168.12.22/24 network=192.168.12.0 broadcast=192.168.12.255 interface=lan comment="" disabled=no
add address=192.168.2.3/24 network=192.168.2.0 broadcast=192.168.2.255 interface=line1 comment="" disabled=no
add address=192.168.3.11/24 network=192.168.3.0 broadcast=192.168.3.255 interface=line2 comment="" disabled=no

3. set mangel
/ip firewall mangle
add chain=prerouting in-interface=lan connection-state=new nth=1,2,0 action=mark-connection new-connection-mark=one passthrough=yes comment="" disabled=no
add chain=prerouting in-interface=lan connection-mark=satu action=mark-routing new-routing-mark=one passthrough=no comment="" disabled=no
add chain=prerouting in-interface=lan connection-state=new nth=1,2,1 action=mark-connection new-connection-mark=two passthrough=yes comment="" disabled=no
add chain=prerouting in-interface=lan connection-mark=dua action=mark-routing new-routing-mark=two passthrough=no comment="" disabled=no

4. set Nat
/ip firewall nat
add chain=srcnat connection-mark=one action=src-nat to-addresses=192.168.2.3 to-ports=0-65535 comment="" disabled=no
add chain=srcnat connection-mark=two action=src-nat to-addresses=192.168.3.11 to-ports=0-65535 comment="" disabled=no

5. Set Route
/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=one comment="" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.3.2 scope=255 target-scope=10 routing-mark=two comment="" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.3.2 scope=255 target-scope=10 comment="" disabled=no <<--default route

Source : http://mikrotik.unimedcenter.org/?p=112